https://dnnsoftware.com/ is down

Incident Report for IgniteTech

Resolved

The incident is now resolved.
Posted Nov 14, 2025 - 01:55 UTC

Investigating

Our team is currently investigating an issue where https://dnnsoftware.com/ is down, We will provide further updates as they become available.
Posted Nov 14, 2025 - 01:16 UTC
This incident affected: DNN Software.