Kiln access blocked

Incident Report for IgniteTech

Resolved

Kiln should be accessible now.
Posted Sep 09, 2026 - 04:03 UTC

Investigating

We are investigating the root cause of a maintenance page showing up when attempting to access Kiln.
Posted Sep 09, 2026 - 03:47 UTC
This incident affected: FogBugz (Kiln).