Cloudflare Incident Impacting DNN

Incident Report for IgniteTech

Resolved

The Cloudflare outage has now been resolved: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 22:59 UTC

Monitoring

Cloudflare has resolved the issue and we are now monitoring the issue
Posted Nov 18, 2025 - 15:29 UTC

Investigating

We are currently experiencing an ongoing Cloudflare incident that is impacting https://store.dnnsoftware.com/.
You can follow the upstream incident here: https://www.cloudflarestatus.com/

We are actively monitoring the situation and will continue to provide updates as Cloudflare works toward a resolution.
Posted Nov 18, 2025 - 13:32 UTC
This incident affected: DNN Software.