FogBugz is slow or failing to load with 504 Gateway Timeout

Incident Report for IgniteTech

Resolved

The incident has been resolved.
Posted Aug 05, 2025 - 03:21 UTC

Monitoring

A fix was implemented and we are monitoring the results.
Posted Aug 04, 2025 - 16:24 UTC

Investigating

We are currently investigating an issue where FogBugz instance is slow or failing to load, resulting in 504 Gateway Timeout errors.
Posted Aug 04, 2025 - 14:05 UTC
This incident affected: FogBugz (Website).