StreetSmart App Login & Device Activation Errors

Incident Report for IgniteTech

Resolved

The issue affecting login and device activation in the StreetSmart app has been resolved.
Posted Dec 30, 2025 - 00:33 UTC

Update

The application of the fix is successful currently. No new issues have been reported.
Posted Dec 29, 2025 - 05:03 UTC

Monitoring

A fix has been implemented, and we are monitoring the affected customers.
Posted Dec 28, 2025 - 21:07 UTC

Identified

We have received reports that some customers are impacted by failures on some cellular carriers due to a DNS issue. We are working with the carrier to resolve this issue.
Posted Dec 28, 2025 - 13:06 UTC

Monitoring

A fix has been implemented, and we are monitoring the affected customers.
Posted Dec 28, 2025 - 04:20 UTC

Investigating

We have received reports that the issue is still reproducible for some customers. We are currently investigating the root cause.
Posted Dec 27, 2025 - 17:13 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 27, 2025 - 13:09 UTC

Monitoring

A fix has been implemented, and we are monitoring the impact.
Posted Dec 27, 2025 - 11:49 UTC

Update

We are continuing to investigate an issue affecting a number of StreetSmart mobile app users. Our team is working on identifying the root cause and will share updates as they become available.
Posted Dec 27, 2025 - 00:28 UTC

Investigating

It seems like the issue is still reproducible for some customers. We are currently investigating the root cause.
Posted Dec 26, 2025 - 20:44 UTC

Monitoring

The issue has been identified, and the fix has been applied. We can no longer reproduce the issue. Should you have any other problems, please report them to the customer support.
Posted Dec 26, 2025 - 19:41 UTC

Investigating

We are currently investigating an issue affecting the StreetSmart mobile application where users may encounter a “Server communication error” when attempting to log in or activate their device. This may prevent successful phone number verification and account activation.

Our team is actively working to identify and resolve the underlying cause. We will provide updates as more information becomes available.
Posted Dec 26, 2025 - 18:19 UTC
This incident affected: StreetSmart.