StreetSmart Workforce app missing from iOS App Store

Incident Report for IgniteTech

Identified

We are aware that some customers are unable to access the app on their devices. We continue to work to engage Apple to resolve.

MDM-managed deployments: If you deploy our app via MDM, we recommend temporarily pausing or lengthening app sync/validation for this app and avoiding manual re‑installs until we confirm resolution

All other users: If the app is currently installed on your device, it will continue to function normally. Please do not delete it.

We will provide an update once the issue is resolved with steps to restore access.
Posted Feb 28, 2026 - 17:15 UTC

Update

We require Apple’s help with this problem and are attempting to work directly with Apple to resolve.
Posted Feb 28, 2026 - 14:02 UTC

Investigating

We are currently investigating an issue related to Streetsmart Workforce app being unavailable from App Store.
Posted Feb 28, 2026 - 11:28 UTC
This incident affects: StreetSmart.