StreetSmart Application Is Missing from Google Play

Incident Report for IgniteTech

Resolved

The StreetSmart Application is back online and available for download from the Google Playstore - https://play.google.com/store/apps/details?id=com.streetsmart.advantage&hl=en.

We have monitored further and did not observe any further issues. We thank you for your patience.
Posted Feb 10, 2025 - 03:16 UTC

Investigating

We are currently working on a new version of the app that is going to be released shortly. In the meantime, you can download the latest version APK file from the link below: https://support.streetsmartmobile.com/hc/en-us/articles/16139452075922-StreetSmart-Application-Is-Missing-from-Google-Play
Posted Jan 28, 2025 - 00:26 UTC
This incident affected: StreetSmart.