Delayed inbound email processing for some FogBugz mailboxes

Incident Report for IgniteTech

Monitoring

We identified delayed inbound email processing affecting a subset of FogBugz email integrations. A configuration change has been applied to the affected integrations, and processing has resumed for those validated so far.

We are continuing to monitor recovery and validate the remaining affected integration. We will provide a final update once validation is complete.
Posted Jul 27, 2026 - 14:07 UTC

Identified

We identified an issue in the endpoint-discovery path used by a subset of Exchange Online mailbox configurations. We are applying a mitigation to bypass the affected path and validating recovery across affected mailboxes.

Delayed inbound email processing may continue while remediation is in progress.
Posted Jul 27, 2026 - 03:30 UTC
This incident affects: FogBugz (Email).