Email Delivery Issues

Incident Report for IgniteTech

Resolved

The issue affecting email delivery for forms and reports has been resolved. Emails are now being delivered as expected.
Posted Dec 30, 2025 - 00:25 UTC

Monitoring

We have identified and resolved an issue affecting the delivery of scheduled and manual email reports in StreetSmart. The system is now fully operational and emails are being delivered as expected. If you continue to experience issues, please contact support.
Posted Dec 29, 2025 - 16:02 UTC

Investigating

We are investigating an issue affecting email delivery for forms and reports. Some emails may be delayed or not delivered as expected. We will provide updates as more information becomes available.
Posted Dec 29, 2025 - 14:32 UTC
This incident affected: StreetSmart.