Placeable Bing-related outage

Incident Report for IgniteTech

Resolved

The incident impacting Placeable features that rely on the Bing API has been resolved. The application is now fully operational again.
Posted Oct 30, 2025 - 13:48 UTC

Identified

Some of the Placeable features that rely on the Bing API are currently down due to the ongoing Bing outage https://azure.status.microsoft/en-us/status. We are investigating the issue further.
Posted Oct 29, 2025 - 20:44 UTC
This incident affected: Placeable.