Streetsmart login issues

Incident Report for IgniteTech

Resolved

We have now resolved the login issues for Streetsmart.
Posted Feb 18, 2026 - 22:30 UTC

Monitoring

The issue causing login and sync issues for Streetsmart has now been resolved.

We are actively monitoring the situation to ensure that there are no further issues.
Posted Feb 18, 2026 - 11:35 UTC

Identified

We have identified the issue causing login and sync issues with the StreetSmart app.
Our Infrastructure team has implemented a fix for the login issues, and we are working on a fix for the sync issues.
Posted Feb 17, 2026 - 23:37 UTC

Investigating

We have received a number of reports about people being unable to log in to Streetsmart. We are currently investigating the issue and assessing the blast radius. Users facing the issue should create a support ticket.
Posted Feb 17, 2026 - 20:11 UTC
This incident affected: StreetSmart.