FogBugz email delivery
Incident Report for IgniteTech
Resolved
A permanent fix was applied and we have received positive feedback following it. Should you have further issues, do not hesitate to reach out to support, and we will be happy to assist further!
Posted Dec 05, 2023 - 09:14 UTC
Investigating
We have received reports of intermittent issues with email delivery to the outlook.com and hotmail.com domains. We are in contact with the relevant parties and will provide an update as soon as we have more information to share.
Posted Nov 29, 2023 - 14:55 UTC
This incident affected: FogBugz (Email).